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About this Documentation

Welcome

Welcome to the User Guide of IRISPowerscan™ Server.
 

Purpose

The aim of this documentation is to help you get up to speed with using IRISPowerscan™ 
Server. It covers the installation and configuration.
The descriptions in this documentation are based on the Windows® 10 Operating System. 
All information is subject to change without prior notice.
 

Legend 

or WARNING.  A WARNING informs you of danger, harm, or consequences that 
exist.

or Caution.  A CAUTION advises you to act with care.  

or Note.  A NOTE tells you an additional information that is good to know.

or Tip.  A TIP is a piece of advice or expert information.
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About IRISPowerscan™ Server
By means of IRISPowerscan™ Server, Administrators can set up a Client Server Architecture
between IRISPowerscan™ Server and multiple IRISPowerscan™ Workstations - or Clients on 
the same LAN network.
This way the three activities of IRISPowerscan™ - being Capture, Validation and Export - 
can be divided over different Clients and you can set up an entire workflow process. Some 
users take care of the scanning, while others do the index validation and the server does 
the export (most commonly used).
 

How does it work?

An Administrator configures a Project that different IRISPowerscan™ Clients will work 
on.
He exports the project from the standalone application and imports it within the 
IRISPowerscan™ Server application.
He configures the different users and their permissions inside the IRISPowerscan™ 
Server application.
The users connect their IRISPowerscan™ Client to the IRISPowerscan™ Server using 
the credentials they obtain from the Administrator.

Client-Server overview
 



Page 5

•

•

•

◦

◦
◦

◦

IMPORTANT

Before modifying a project, make sure that no batches are pending for that project. 
Failing to process all the batches before changing a project can lead to random errors.
 

The IRISPowerscan™ Server application must be installed on a computer/server to 
which all required IRISPowerscan™ Clients have access.
The IRISPowerscan™ Server application itself can only be accessed via the computer 
on which it is installed, or via standard Remote Desktop Connection. There is no 
remote control or Web control foreseen.
The Projects that are shared via IRISPowerscan™ Server cannot be modified via the 
IRISPowerscan™ Server application or by IRISPowerscan™ Clients. These Projects are 
Read-only. The only setting in a Project that can be changed are the Scan Source 
settings.
If other modifications need to be made to a Project, an Administrator must:

Export the Project from the IRISPowerscan™ Server and import it to an 
IRISPowerscan™ standalone application.
Do the required modifications.
Export the Project back to the IRISPowerscan™ Server application.
The original project on the Server will be overwritten if it has not been 
renamed.
Restart the required IRISPowerscan™ Clients again.
The modified version of the Project will now be copied to the Clients.

•

•

Standalone implies being disconnected from the Server. Even an 
Administrator cannot modify a Project if his IRISPowerscan™
application is still connected to IRISPowerscan™ Server.
When working with IPS Server, a Standard Operating Procedure 
must be in place. The IPS server administrator must be trained and 
must control the daily production. Some project statuses or batch 
statuses may require some attention and appropriate actions.
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Step 1: Install the IRISPowerscan™ Server

System Requirements

•

•

•

•

Running IRISPowerscan™ on a virtual machine can be unusable, 
particularly on low specification hosts. Ensure that you allocate at least 4 
cores / virtual processors when creating the guest VM.
Please ensure that your system is up-to-date with the latest Windows 
Updates from Microsoft prior to the installation of IRISPowerscan™.
Systems using budget or low specification components (particularly small 
form factor computers) can be incompatible with IRISPowerscan™. 
Please seek advice from IRIS Support should this be a concern providing 
the manufacturer, model and specification of the system.
Terminal Server and Virtual Desktop are not supported.

 

IRISPowerscan™ Server

REQUIREMENTS OS CPU RAM HDD

Recommended 
for IPS SERVER

Windows 
Server 2019, 

2022
(64-bit)

If they are vCPU, it is 
highly recommended 

to have 8.
(to have the final value 

if you have vSocket 
and vCore, simply 

multiply the number of 
vCore per the number 
of vSocket to get the 

total amount of vCPU.

16 GB
Fast IO is 

highly 
recommended

100 GB free 
hard disk space
SSD drives are 

highly 
recommended.
Fast IO is highly 
recommended

Network 
requirements

Internet connection
The Network infrastructure must be reliable and must have a 
decent bandwidth. The performance of the IRISPowerscan™
Client Server is highly dependent on the quality and performance 
of the network and the server/computers.
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• The Firewall and anti-virus software should block neither the 
ICMP ping commands, nor the HTTP port on which 
IRISPowerscan™ Client Server is set up.

 

IRISPowerscan™

REQUIREMENTS OS CPU RAM HDD

Recommended 
for IPS*

Windows 10, 
11

(64-bit)

Processor Intel i7 or 
similar.

2.6 GHz or faster, with 
at least 4 cores

16 GB

50 GB free 
hard disk 

space
preferably on 
a Solid State 
Disk drive.

Network 
requirements Internet connection

* IPS Standalone, Clients or Unattended
** WARNING: you won't be able to use a Scanner if you use IRISPowerscan™ on Windows 
Server OS.
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Licensing rules

Each Client requires a Central Management add-on.
Capture as a Service on the Server requires a PPM licence. 
Export to iHQC on the Server requires a PDF compression licence.
If the Server does the Export, it requires the necessary connectors.
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Installing IRISPowerscan™ Server

Preliminary notes:
The IRISPowerscan™ Server application must be installed on a computer to which the 
IRISPowerscan™ Clients have access.
In a Client-Server configuration, both IRISPowerscan™ Server and IRISPowerscan™ Client 
applications must have the same version number (the 3 leftmost numbers), i.e. 12.0.6.
Although IPS 11 and 12 can be installed on the same computers, they cannot work 
together.
 
To install IRISPowerscan™ Server:

Download the IRISPowerscan™ package from the I.R.I.S Partner Portal.
Double-click IRISPowerscanServer.msi
Select I agree to the License terms and conditions.
Click Install and follow the on-screen instructions.
Click Close to finish the installation.

 

If you want to use the IRISPowerscan™ Server Service to do the Import (Server 
is selected in the Capture activity), for instance to use IRISPowerscan™ Server 
for Watched Folders, you need a Speed license (40, 90, 110, 140 or unlimited 
PPM) on IRISPowerscan™ Server. This Speed license comes with a regular 
IRISPowerscan™ package. You must select the one that best matches your 
requirements in terms of import speed, output connector and iHQC PDF 
compression.

 
To activate this license, simply follow the installation and activation procedure.
 

Configure your Anti-Virus Software

The anti-virus installed on your PC scrutinizes all the files that are being written on your 
hard disk. This may dramatically slow down the writing speed of the images being scanned 
with IRISPowerscan™ or simply prevent IRISPowerscan™ from running. Your target 
production level may thus not be reached.
 

https://iriscorporate.com/portal/
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In order to avoid such a problem, you must properly configure your anti-virus and exclude 
from the process the list of folders into which your images are being placed. This 
configuration depends on the anti-virus used. Please refer to your anti-virus manual to 
define the required settings.
 
In IRISPowerscan™,

the folders to be excluded are:
%appdata%\IPS12
%programdata%\IPS12
C:\Program Files\IRISPowerscan 12

Some anti-virus do not support %FolderName% syntax. In those cases, enter 
the full path, i.e. C:\Users\YourName\AppData\Roaming\IPS12 and C:
\ProgramData\IPS12

 
the executables to be excluded are:

C:\Program Files\IRISPowerscan 12\IPSxConsole.exe
C:\Program Files\IRISPowerscan 12\IPSxService.exe
C:\Program Files\IRISPowerscan 12\IRISPowerscan.exe
C:\Program Files\IRISPowerscan 12\Scan32\IPSxScan.exe
C:\Program Files\IRISPowerscan 12\IPS11PdfConverter.exe
C:\Program Files\IRISPowerscan 12\PDFConverter.exe
C:\Program Files\IRISPowerscan 12 Server\IPSxServer.exe
C:\Program Files\IRISPowerscan 12 Server\IPSxServerManager.exe

 
If you are using the Watched Folder feature, you must add all the watched folders in the 
exclusion list.
 
Without appropriate exclusions, random errors may occur.
For example:

Some batches can be stuck in capture, validation or export
Errors of missing files
Errors of concurrent accesses to files

 
In such cases, exclusions must be added.
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Configure IRISPowerscan™ Server

Start the IRISPowerscan™ Server Service

The IRISPowerscan™ Server Service should start automatically.
To check if it is started:

Open the IRISPowerscan™ Server application.
If the traffic light icon in the bottom ribbon is green, the service is started.
If the traffic light icon is red, click it to start the service.

When setting up your users, groups and projects on the server, we recommend 
you to stop the IRISPowerscan™ Server Service. Once all your settings are 
correct and ready, then you can start the IRISPowerscan™ Server service.

 

Open the Required Port

By default, TCP port 8080 must be open on the IRISPowerscan™ Server in order for Clients 
to connect to the Server.
If that port is used by another application, you can configure IRISPowerscan™ to use a 
different one.
To change the port:

Start the IRISPowerscan™ Server Service as described above.
On the computer where IRISPowerscan™ Server is installed, open a file explorer and 
go to %programdata%\IPS12Server\LocalProjects.
Right-click settings.xml and click Edit.
Change the serverPort value from 8080 to another one.

Save the settings.xml file.
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• Click the traffic lights icon again to stop and then to restart the IRISPowerscan™ 
Server Service.

If the default port has been changed, the port information must be 
communicated to the different IRISPowerscan™ Clients. They need it 
in order to connect to the Server.
The default port does not need to be specified.
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Step 2: Install the IRISPowerscan™ Clients
On each computer you want to use as IRISPowerscan™ Client you need to install an 
instance of the IRISPowerscan™ application.
To install IRISPowerscan™:

Download the IRISPowerscan™ package from the I.R.I.S Partner Portal.
Run the IRISPowerscan.msi.
Click Next and follow the on-screen instructions.
Click Finish to finish the installation.

You can find your activation code in the email you received from I.R.I.S.

 

https://iriscorporate.com/portal/
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Step 3: Configure a Project on the 
IRISPowerscan™ standalone application
How to configure a Project is explained in the IRISPowerscan™ User Guide and How To 
Guide.

•

•

•

The Project can only be configured in the IRISPowerscan™ standalone
application, when it is disconnected from the IRISPowerscan™ Server.
The Project cannot be configured in the IRISPowerscan™ Server
application or on IRISPowerscan™ Clients that do not have Administrator 
rights.
If changes need to be made, export the Project from the IRISPowerscan™ 
Server application and import it back into the IRISPowerscan™
standalone application, where an Administrator can modify it.

Export the Project

When you are done configuring the Project in the standalone application, export it.
In the IRISPowerscan™ standalone application, click File > Open.
Select the Project you want to export.

Click the up arrow to export the project.
Store it in a location to which you have access from the IRISPowerscan™ Server.
The project will be stored as .zip file.
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Step 4: Configure the user groups on the 
IRISPowerscan™ Server
In order for IRISPowerscan™ Clients to connect to the Server and access shared projects, 
they need the necessary user permissions and credentials. You can configure the 
User permissions, assign users to a Group and determine their credentials with the 
IRISPowerscan™ Server application.

Creating User Groups

The user permissions are defined in the Groups section. Each user belonging to the same 
group has the same permissions. This way you avoid having to configure the permissions 
for each user separately.
To create a user group:

Open the IRISPowerscan™ Server application.
In the Home tab, select Groups and click Create.
The new Group is added to the Groups list.
Double-click the new group to edit its Permissions.
Or select it and click the Edit button.

Creating user groups
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Select the required Permissions from the list and click OK.
Administrate: user may access the Users, Groups and Batches sections in the 
IRISPowerscan™ main application's Application menu.

Tip: do not enable this option for Clients.
Delete Project: user may delete projects.
Export Project: user may export projects so they can be used in other 
workstations or by the IRISPowerscan™ Server.

Tip: do not enable this option for Clients.
Settings: user may modify the settings of the input source.
Create batch or document: user may create new Documents and Batches.
Delete: user may delete elements.
Undelete: user may undelete Pages that are marked for deletion.
Split: user may split batches and documents.
Merge: user may merge batches and documents.
Reorder: user may reorder the pages.
Cut: user may cut elements.
Copy: user may copy elements.
Paste: user may paste elements.
Swap: user may swap the sides of a Duplex page.
Attach: user may attach pages.
Detach: user may detach pages.
Rotate: user may rotate pages.
Crop: user may crop the size of pages.
Fill: user may fill parts of the pages.
Customize: user may customize the view of the projects.
(by means of the Show/Hide tools on the View tab)
Designer: not relevant in client-server mode. No impact.

Now you must add at least one User to the Group.
 
Note that there are also two default groups: Supervisors and Operators.
The Supervisors group has access to all permissions. In other words, Supervisors can do all 
configuration actions. The permissions of the Supervisors group cannot be modified.
The Operators group is by default allowed to scan and process documents in 
IRISPowerscan™ but cannot do advanced configurations. The permissions of the Operators 
group can be modified.
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Creating Users

To add a user to a group:
Select Users and click Create.

The new User is added to the Users list.
Double-click the new user to edit its Settings.
Or select it and click the Edit button.
Enter a Name for the new user.
To apply a password, click Change password.
If this is the first time you attribute a password, leave the Old Password field empty, 
enter the password in the New Password field, and confirm it.
To change the default user icon, select another icon from the list.
If the user is/should be part of a domain, enter the domain in the Domain field.
The Status of the new user is by default set to Active.
To deactivate the user later on, return to this menu and select Inactive.
Select the interface language from the Language list.
When the user logs in, the interface is displayed in the selected language.
Select the Unit in which measurements must be displayed: centimeter, inch or pixel.
Select one or more Groups to which you want to add the user.
Once you have created a user in IRISPowerscan™ Server, he can connect his 
workstation to the Server and log in using his credentials.

Note that there are 2 default Users in IRISPowerscan™: guest and SysAdmin. Both belong 
to the Supervisors group and therefore have all Permissions.

We recommend you to create new groups and new users that best describe 
your application.
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Step 5: Import the Project into the 
IRISPowerscan™ Server

Start the IRISPowerscan™ Server application.
Go to Home > Projects menu.
If you are using IRISPowerscan™ Server application for the first time, the Projects list 
should be empty.
Click Import.
Now browse for the project you exported from the IRISPowerscan™ standalone 
application. The project is in the .zip format.
Then select Open.

Determine which User Groups may carry out which activity: Capture, 
Validation, Export

In IRISPowerscan™ Server, click Projects.
Double-click the Project you configured.
Select which activity should be carried out by which User Group.

If you choose Server as Group, the activity will be carried out by 
IRISPowerscan™ Server in the background, and will not require a user 
intervention.
We recommend you NOT to assign an activity to Service, but instead 
to a group or server.
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Step 6: Connect Client to the 
IRISPowerscan™ Server
In order for users to collaborate on projects that are managed by the IRISPowerscan™ 
Server, they must connect their IRISPowerscan™ Client to the IRISPowerscan™ Server and 
log in using the credentials that were specified in the IRISPowerscan™ Server.
 

Step 1: Connect an IRISPowerscan™ Client to the IRISPowerscan™ Server

Open the IRISPowerscan™ Client.
Click File > Info > Generalities.
In the IRISPowerscan™ 12 Server section, enter the address where the 
IRISPowerscan™ Server is installed.
For instance jsmith.
Then click Connect.

When the connection is established, click Restart now to restart the application.
You can check on the client-server connections in the Users configuration:
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Step 2: Log in from the IRISPowerscan™ Client

Open the IRISPowerscan™ Client.
Click File > Login.
Click Yes to restart the application.
When the application restarts, enter your Domain\Username and Password and click 
OK.

Select the Project you want to open.
The Projects that are listed here are the ones managed by the Server. A Client only 
sees the Projects to which he has access.
Carry out the actions for which you have permissions and click Process to go to the 
next step of the process.

When processing heavy batches, it may take some time for the 
batches to be moved to the next step.
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Example of a Workflow
In this section we provide an example of workflow of how different IRISPowerscan™ 
Clients can collaborate using a shared project.
In our workflow, Client 1 does the Capture, Client 2 does the Validation, and the Export is 
done automatically by the Server.

Do not change a project when batches are pending.
Stop the service when changing groups, users or projects. 

 

IRISPowerscan™ Server Configuration

Create the required user group and user in IRISPowerscan™ Server

Add the group "Group - Capture", add "User 1" to the group "Group - Capture" and 
assign a password.
Add the group "Group - Validation", add "User 2" to the group "Group - Validation" 
and assign a password.

See Define Groups and Users if necessary.
 

Share a project on which you want the Clients to collaborate

Configure the project in the IRISPowerscan™ standalone application, export the 
project and import it into the IRISPowerscan™ Server application.
Open the imported project in IRISPowerscan™ Server and specify which activity 
should be carried out by which User Group.
In our example select:

Select "Group - Capture" in the Capture list.
Select "Group - Validation" in the Validation list.
Select "Server" in the Export list.
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When the configuration is done, click the traffic lights icon in the bottom left corner 
to start or restart the IRISPowerscan™ Server Service.

Workflow

User 1: does the Capture

Start the IRISPowerscan™ Client.
Connect the Client to the Server via File > Info > Generalities.

Go to File > Login and enter your credentials.

Open the project and click Scan (in the Ribbon of the Navigation view).
 

To check the status of the batches, go to File > Manage. The batches in 
progress are listed.
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Notice the 3 tiny LEDs next to the Batch icon:  . They indicate the different steps: 
Capture, Validation and Export. Each of the LEDs also indicates the status of the 
corresponding activity in a different color:

Color/
Activity Capture Validation Export

Grey not started not started not started

Orange   ready to be 
processed

ready to be 
processed

Orange 
(blinking) in progress in progress in progress

Green completed completed completed

Red in error in error in error

 
So a batch with the leds green, orange and grey means the Capture is done, the Validation
is ready to be done and the Export is not yet ready.
 

When the scanning is done, click Process.
The task of User 1 is now completed. The batches are transferred to the 
IRISPowerscan™ Server where they are available to User 2 to do the Validation.

User 2: does the Validation

Start the IRISPowerscan™ Client.
Connect the Client to the Server via File > Info > Generalities.
Go to File > Login and enter your credentials.
Open the project. You will notice that the batches that were scanned by User 1 are 
ready for validation.
Click Open, select the batch you want to validate and click Open.
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• Do the Validation. When you are done, click Process.
The validated batch will be transferred to the IRISPowerscan™ Server, where it is 
exported automatically to the configured destination.

If User 2 does not want to do the validation, he can discard the batch to 
release it for another User. To do so, click on the arrow below the Process
button and select Discard.

Logs Information

The Administrator can access the Logs information via the IRISPowerscan™ Server
application (Home > Logs). There you can find the events reporting each Client's actions, 
their batches and their associated activities.
Note that Clients cannot access these Server logs, they can only access the information 
about their own batches.
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Batch Lifecycle Information

All batches and their status can be checked by the Administrator in the 
IRISPowerscan™ Server application via Home > Batches.

Double-click a Batch to display its lifecycle information.
See the 3 tiny LEDs meaning.

The Administrator has the ability to change the status of a batch, or delete a batch in 
the IRISPowerscan™ Server, if for instance an error occurred.
To move the batch to a previous step, use the return arrows.

Action buttons (tooltips available in the User Interface)
 



Page 27

•

•

•

•

•

•
•

•

Administrators can do the following actions:

 Unlock a batch locked by a Client.

 Move to validation: move the batch to validation activity.

 Move to export: move the batch to export activity.

 Show a batch history.

 Delete a batch at any stage.
When Clients are still logged in and connected to the Server, a warning message 
is displayed as soon as a checked out batch is deleted or reset on the server. 
This warning message appears in Navigation mode.

Client side: warning message
The batch goes back to the previous step and Clients need to perform their task 
on the batch again.
The Clients, in turn, can do the following actions:

Delete a batch (provided they have the Administrate Permission).
Redo the Capture.

When a Validator opens a batch for validation, that batch will be locked (greyed out) 
to other clients. If this Validator leaves his computer without completing the 
validation, the batch will remain in that state until either the Validator returns to 
finish the job or until the Administrator/Production Manager* unlocks the batch on 
the Server and resets it to the "Validation Ready" state.

*In a Client-Server Architecture it is recommended to have a Production 
Manager who checks the production on a daily basis to guarantee that all 
batches are correctly processed without errors. In case of errors, he must check 
what happened, take corrective actions, restart the processing of the batch, 
restart the validation or ask for a batch rescan.
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•

Batch states and lifecycle
 

If a Client fails or cannot see his batches anymore, the batches are not lost. They are 
stored on the Server as a fail safe mechanism.

The server admin has full powers with NO undo possibilities. That means 
deleting or changing batches, groups or users can lead to data loss if not done 
carefully and at the right time.
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Batch Activity View & Statistics
IRISPowerscan™ Server brings a new batch activity view and statistics.
The batch activity view tells you the amount of batches that have been processed, or 
waiting to be processed or in error.

Batch view
In the project view, you can see some statistics for each one of your projects.

Project view and statistics
 
Here are the information you can see for each projects (cf. Glossary):
BPD (batches per day)
IPM  (images per minute)
IPD (images per day)
Avg IPM (average images per minute)



Page 30

1.

 

Reporting and Exporting Server Statistics

Statistics

Under the Info > Generalities tab, you can find the Statistics section where you can export 
or reset the server statistics.
Resetting the statistics flushes all Processed, BPD, IPM, Avg IPM and IPD data.

The Export statistics button allows the user to save the data in XML format:

  

<Statistics date="9/5/2024">
<Projects>
  <Project name="Server03" bpd="4" ipd="200" ipm="151" avgIpm="109" >
  <Total None="0" OnError="1" Processed="4" OnHold="0" />
  </Project>
  <Project name="Server01" bpd="4" ipd="200" ipm="143" avgIpm="108">
  <Total None="0" OnError="0" Processed="4" OnHold="1" />
  </Project>
  <Project name="Server02" bpd="4" ipd="200" ipm="126" avgIpm="111">
  <Total None="0" OnError="1" Processed="4" OnHold="0" />
  </Project>
</Projects>
<Total None="0" OnError="2" Processed="12" OnHold="1" />
</Statistics>
  

Reporting

Under the Info > Reporting tab, you can find the Reporting section.
 

Logging
Send email on error: select this option if you want the user or users to receive an 
email notification when a project is on error.
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Batch on error: select this option if you also want the same user or users to receive 
an email notification when a batch is on error.
You can set the Timeout time after which the system stops trying to send the email. 
The default time is 60 seconds.
If necessary select Use SSL to use a Secure Socket Layer.
Enter your User name and Password.
When you are done, click Send test to send a test email.

Activity Report
You can generate an activity report. 

Check the "Enable activity reports" box. 
Define the settings: 

Logs path: give the path where to store the logs file of activity log file 
(local disk or network). The default path is the local path C:
\ProgramData\IPS12\Temp.
Maximum activity file size: give the maximum size of the file (in MB). A 
new file is created every xxx MB.
Frequency of activity file archiving: select an archiving frequency. A new 
file is created daily, weekly (select a day of the week), monthly, or yearly.

Check the "Enable automatic monthly reporting" box.
Give a path for storing the report.  The default path is C:
\ProgramData\IPS12\Report.
You can also generate the report manually on request by clicking on Generate 
report.

The content of the report includes the following activities:
Date and time of activity report
Cumulative activities for all projects
Cumulative activities by project and user

Activities are: 
Activities executed inside the Viewer. 
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Composition activities
Export activities 
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Recipients and Shared projects
IRISPowerscan™ Server can also serves as Central management for sharing projects only, 
without synchronizing the batches/documents.  
This is useful for the following scenario: an administrator wants to send projects to defined 
Recipients, without necessarily having a view of the activities. All activities are done and 
kept on the Client side. 
A Recipient group is a virtual group (rather than a group of users) that has all permissions 
except administrative. With recipient groups, any member who knows the recipient's 
credentials can access projects shared by the Server and update them on the Client side. 
 
This use can be managed via the Recipients and Shared projects menus in the 
Configuration pane. 

No documents are transferred to the Server when using Shared projects.
After the first connection and synchronization between Client and Server, Shared 
projects can be used offline on the Client.
Shared projects are automatically updated/synchronized when a new project is 
uploaded to the server and a connection is established. (An update is not complete 
until you restart the application and log in with the same Recipient).
The Shared projects menu is where you import projects and assign a Recipient or the 
Service to each activity.

 

Recipients

To create a Recipient:
Open the IRISPowerscan™ Server application.
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In the Home tab, select Recipients and click Create. A pop-up window opens.
Select a name, a description and a password.
Click OK.
The new Recipient is added to the Recipients list.
Double-click the new Recipient to change the settings.

 

Shared Projects

To add a Shared project:
Go to Shared projects and click Import.

To define/edit a Shared project: 
Go to Shared projects. 
Select a project. 
Double-click the project or click Edit. A pop-up window opens.

Assign a Recipient to each activity or assign the activity to the Service. 
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Enable support for SSL connection
The IRISPowerscan™ Server optionally supports SSL connection.
To enable this connection, a valid SSL certificate must be installed on the server machine to 
authenticate the server.
The certificate can be signed by a publicly trusted certification authority or by a self-signed 
certificate.
In all cases, the SSL certificate must be linked to the HTTPs port of the IRISPowerscan™ 
Server.

How to work with a self-signed certificate

The following procedure explains how to use a self-signed certificate to authenticate your 
server with OpenSSL on Windows 10.
 
Prerequisites

OpenSSL is installed on the machine.
You have administrator rights on the machine.

 
Procedure

Values between [  ] must be replaced by values of your choice.

 
On the server machine
The point of the following steps is to create a certification authority (ca) and use it to sign 
the server certificate.
 

Start a command prompt as administrator.1

If necessary, update the PATH environment variable to include the path to OpenSSL.

set PATH=%PATH%;C:\Program Files\Git\usr\bin

2

Go to the directory (cd) where you want to save the files generated (keys, certificates, 
signature request).

cd [path-to-the-directory]

3

Create a Certification Authority.4
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◦

Create an encrypted key.

openssl genrsa -aes256 -out [ca-filename].key 4096

When prompted, enter the password of your choice for the generated key.
Generate a root certificate.

openssl req -new -x509 -sha256 -days 3650 -key [ca-filename].key 

-out [ca-filename].crt

You will need to give the password for the key and provide the information 
requested for the certificate - most of the information can be left blank, with 
the exception of the organisation name.

◦

◦

◦

◦

◦

◦

Create a server certificate.
Create an encrypted key.

openssl genrsa -out [certificate-filename].key 4096

Create a Certificate Signing Request.

openssl req -new -sha256 -subj "/CN=[what-you-want]" -key 

[certificate-filename].key -out [certificate-filename].csr

Create an external OpenSSL config file.

echo subjectAltName=DNS:[server-fqdn],IP:[server-ip] >> extfile.cnf

Generate a server certificate with the CSR and the key and sign it with the root 
key of the Certification Authority.

openssl x509 -req -sha256 -days 365 -in [certificate-filename].csr 

-CA [ca-filename].crt -CAkey [ca-filename].key -out [certificate-

filename].crt -extfile extfile.cnf -CAcreateserial

You will have to give the key password of the Certification Authority.
(Optional) View the generated certificate.

openssl x509 -in [certificate-filename].crt -text -noout

Combine server certificate and key in a .pfx file.

openssl pkcs12 -export -out [certificate-filename].pfx -inkey 

[certificate-filename].key -in [certificate-filename].crt -certfile 

[ca-filename].crt

5

◦

◦
▪
▪

Import certificates (ca and server) in the server certificate store.
Start Microsoft Management Console (MMC).

mmc

Add the Certificates snap-in to the Console Root.
Select Console Root.
Go to Menu File > Add/Remove snap-in.

6
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Make sure that the certificate is in the Personal node of the Local Computer 
store, and that the certificate icon has a key on it.

 
On the client machines
For clients to trust the server certificate, the certification authority must be installed in 
their certificate stores (in the Trusted Root Certification Authorities node). 
If you are in a domain, you can use Windows Group Policy to do this operation globally.
Alternatively, you can use the Certificates MMC snap-in for the user running 
IRISPowerscan™ and for the local computer.
 

▪
▪
▪
▪

◦

▪

▪
▪

▪

◦
▪
▪
▪

▪

Select Certificates in the available snap-in list.
Click on Add to add the snap-in to the Selected snap-in list.
Select certificates for the Computer account and Local computer.
Click on OK.

Import the Certification Authority (CA) certificate in the Trusted Root 
Certification Authorities node.

Expand the Certificates (Local Computer) node to Trusted Root 
Certification Authorities > Certificates.
Go to Menu File > Add/Remove snap-in.
Right-click on Certificates and, in the context menu, select All tasks > 
Import...
Follow the wizard, specifying the [ca-filename].crt as the file to be 
imported.

Import the server certificate in the Personal node of the server.
Expand the Certificates (Local Computer) node to Personal > Certificates.
Go to Menu File > Add/Remove snap-in.
Right-click on Certificates and, in the context menu, select All tasks > 
Import...
Follow the wizard, specifying the [certificate-filename].pfx as the file to 
be imported.

Start a command prompt as administrator.1

◦

◦
▪

Import the certificate (CA) into the client's certificate store.
Start Microsoft Management Console (MMC).

mmc

Add the current user's Certificates snap-in to the Console Root.
Select Console Root.

2
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How to link the SSL certificate to the HTTPs port of the IPS server?

Whether you have chosen to work with a certificate signed by a public certificate authority 
or with a self-signed certificate, the HTTPs port of the IRISPowerscan™ Server must be 
configured with the certificate. Here is the procedure.
 

▪
▪
▪
▪

▪
◦

▪

▪

▪

◦
▪
▪
▪
▪
▪
▪

◦

▪

▪

▪

Go to Menu File > Add/Remove Snap-in.
Select Certificates in the available snap-in list.
Click on Add to add the snap-in to the Selected snap-in list.
Select certificates for the 'Current User' (assuming you are the user 
running IRISPowerscan™).
Click on OK.

Import the Certification Authority (CA) certificate in the Trusted Root 
Certification Authorities node of the current user.

Expand the Certificates (Current User) node to Trusted Root Certification 
Authorities > Certificates.
Right-click on Certificates and, in the context menu, select All tasks > 
Import...
Follow the wizard, specifying the [ca-filename].crt as the file to be 
imported.

Add the local computer's Certificates snap-in to the Console Root.
Select Console Root.
Go to Menu File > Add/Remove Snap-in.
Select Certificates in the available snap-in list.
Click on Add to add the snap-in to the Selected snap-in list.
Select certificates for the 'Computer account and Local computer'.
Click on OK.

Import the Certification Authority (CA) certificate in the Trusted Root 
Certification Authorities node of the local computer.

Expand the Certificates (Local Computer) node to Trusted Root 
Certification Authorities > Certificates.
Right-click on Certificates and, in the context menu, select All tasks > 
Import...
Follow the wizard, specifying the [ca-filename].crt as the file to be 
imported.
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Start a command prompt as administrator.1

(Optional) Check the port bindings to see if the IRISPowerscan™ Server HTTP port 
(8443 by default) is already taken.

netsh http show sslcert

2

(Optional) Use the following command if you need to remove the certificate from the 
port [port].

netsh http delete sslcert ipport=0.0.0.0:[port]

3

◦

◦

◦
◦
◦

Get the server certificate thumbprint.
Start Microsoft Management Console (MMC).

mmc

In MMC, right-click on the server certificate to get the certificate information 
window.
In the Details tab, show <All> fields and navigates to the Thumbprint field. 
Select the Thumbprint field to get its value. 
Copy the value. 

4

Add the certificate binding to the [port] port (8443 if IRISPowerscan™ Server uses the 
default HTTPs port).

netsh http add sslcert ipport=0.0.0.0:[port] certhash=[certificate-

thumbprint] appid={[GUID]} clientcertnegotiation=enable

5
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Legal Information
IRISPowerscan™ Server Users's Guide
The software described in this document is furnished under a license agreement which 
states the terms of use of this product. The software may be used or copied only in 
accordance with the terms of that agreement. No part of this publication may be 
reproduced, transmitted, stored in a retrieval system, or translated into another language 
without the prior written consent of I.R.I.S.
 
Copyright
© 2024 I.R.I.S. SA All Rights Reserved.
I.R.I.S. SA owns the copyrights to the IRISPowerscan™ software, the online help system and 
this publication.
 
Documentation version 1.5 - Software version 12
The information contained in this document is the property of I.R.I.S. Its content is subject 
to change without notice and does not represent a commitment on the part of I.R.I.S. The 
software described in this document is furnished under a license agreement which states 
the terms for use of this product. The software may be used or copied only in accordance 
with the terms of that agreement. No part of this publication may be reproduced, 
transmitted, stored in a retrieval system, or translated into another language without the 
prior written consent of I.R.I.S.
This manual uses fictitious names for purposes of demonstration; references to actual 
persons, companies, or organizations are strictly coincidental.
 
Trademarks
The I.R.I.S. logo, IRISPowerscan™ and IRISPowerscan™ Server are trademarks of I.R.I.S.
OCR ("Optical Character Recognition"), Linguistic technology, ICR ("Intelligent Character 
Recognition") technology, MICR ("Magnetic Ink Character Recognition") technology, BCR 
("Bar Code Reading") technology, OMR (Optical Mark Recognition), iHQC ("intelligent High 
Quality Compression>") technology and HQOCR ("High Quality OCR") technology by I.R.I.S.
Document Generation by I.R.I.S.
Send to the Cloud by I.R.I.S.
All other products mentioned in this User Guide are trademarks or registered trademarks 
of their respective owners.
 



Page 41

Patents
IRISPowerscan™ Serverintegrates the following patent-granted I.R.I.S. technologies: 
US8068684; US8331706; US8666185; JP5501958; US8995780; EP2143039A2; 
EP14163365.1; BE1022166; BE1022635; US8913836; BE1022630; US8897600; BE1022636; 
US8811751; US8411940; BE1021013; US9058517; US9183636; US9311558; BE1025006; 
BE1022562; US9798943; BE1024194; US9836646; BE1024836; CN106462773B; 
CN106255979B; JP6609267; JP6693887B2; GB2571530; BE1026039; GB2572386; 
BE1026159; BE1026095.
 
 
 

I.R.I.S. SA/NV

rue du Bosquet 10, B-1348 Louvain-la-Neuve

+32 (0) 10 45 13 64 - www.iriscorporate.com
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